(更新)Ubuntu 安装 Linux Deepin 截图工具(.deb)

9 Mar
2012
# 作者: wdj / / 本文采用CC BY-NC-SA 2.5协议授权,转载请注明本文链接

深度截图工具,Deepin Scrot,是 Linux Deepin 下特色应用之一。您可以将它看作是 GNOME 截图工具的增强版本,但增强的不是一般般哟~ :)

演示视频

(播放时可选择原画品质,这样操作会看起来更清晰一些)

安装步骤

提示:支持 Ubuntu 11.04+,Debian,Linux Mint等版本。较低 Ubuntu 版本安装过程中会提示 python 版本较低。

#1,下载 .deb 安装包

click here

如果在安装中提示缺少依赖 python-xlib,可利用下面命令安装缺少的依赖:

sudo apt-get install python-xlib

#2,测试下 Ctrl+Alt+A?

如果还没有见到奇迹,我们手动来设置快捷键。

点击“系统设置-键盘-快捷键-自定义快捷键”,点击“+”号。名称填上您喜欢的名字,如“Deepin scrot”,命令填写deepin-scrot,快捷键设置为Ctrl+Alt+A

设置Deepin scrot 快捷键

OK!测试下 Ctrl+Alt+A?

深度截图工具除了支持文字注释、字体选择、自由选色外,还有:

  • 延迟截图(Ctrl+PrintScreen)
  • 快速抓取屏幕(PrintScreen)
  • 抓取光标所在窗口(Alt+PrintScreen)
  • VIA[Planet LD]


    部分童鞋遇到在 Ubuntu 10.04 上安装要求 Gconf 版本过低的问题,这里有个比较好的解决方案:

    1,下载Deepin 截图工具源码:

    git clone git://github.com/lovesnow/deepin-screenshot.git

    2,打开“系统设置-键盘-快捷键-自定义快捷键”,点击“+”号。操作和上面一样。在命令一行须填写 src/目录下的 deepin-scrot 才行,这个文件路径必须正确,否则无法调用!

    这样算是个比较不错的解决方案了。同时感谢 @Hugo 同学指出一个错误,已更正。

    • 作者: wdj
    • Post Time: 2012/03/09 4:43:00 PM
    • In: 技巧
    加入我们 / 来 Wow!Ubuntu 问答社区参与更多讨论

    43 Responses to (更新)Ubuntu 安装 Linux Deepin 截图工具(.deb)

    Avatar

    jazzi

    Firefox 10.0.2 Firefox 10.0.2 Windows XP Windows XP

    March 9th, 2012 at 5:09 pm

    技术不错,就是用户界面设计总感觉没有那个味道,对于桌面来说,界面太重要了

    如果有可能的话在设计这一块建议和国外设计师合作下

    Avatar

    a nerd

    Google Chrome 17.0.963.78 Google Chrome 17.0.963.78 GNU/Linux GNU/Linux

    March 9th, 2012 at 5:40 pm

    用的是Shutter
    一样支持快捷键
    支持延迟截图
    文件自动保存

    只不过截图完成后编辑图片

    Avatar

    huxos

    Google Chrome 17.0.963.56 Google Chrome 17.0.963.56 GNU/Linux GNU/Linux

    March 9th, 2012 at 6:22 pm

    10.04 的要怎么安装 阿

    Firefox 10.0.2 Firefox 10.0.2 Ubuntu Ubuntu

    orvice Reply:

    @huxos, 升级下python试试看

    Avatar

    Hugo

    Google Chrome 18.0.1025.54 Google Chrome 18.0.1025.54 Windows 7 Windows 7

    March 9th, 2012 at 10:58 pm

    “如果在安装中提示缺少依赖 pthon-xlib,可利用下面命令安装缺少的依赖:‘

    不是 缺少依赖 Python 么?

    Google Chrome 17.0.963.78 Google Chrome 17.0.963.78 Windows 7 Windows 7

    自由圣域 Reply:

    @Hugo, 部分 Ubuntu 10.04, 10.10 用户反映无法安装,原因基本是 python 版本较低,gconf2 版本较低 或安装过程中遇到缺少依赖 pthon-xlib 问题。

    Google Chrome 18.0.1025.54 Google Chrome 18.0.1025.54 Windows 7 Windows 7

    Hugo Reply:

    @自由圣域, 我的意思是,不是打少了一个 y 么?

    Avatar

    yetone

    Firefox 2012 Firefox 2012 Arch Linux Arch Linux

    March 10th, 2012 at 11:41 am

    git clone git://github.com/lovesnow/deepin-scrot && python2 ./deepin-scrot/updateTranslate.sh && python2 ./deepin-scrot/src/deepin-scrot

    IceWeasel 10.0.2 IceWeasel 10.0.2 GNU/Linux GNU/Linux

    Bentutu.com Reply:

    @yetone, 华科的老乡?这个周末有空吗?大家在一起聊下。可有时间否?

    Firefox 2012 Firefox 2012 Arch Linux Arch Linux

    yetone Reply:

    @Bentutu.com, 笨兔兔,我在gtalk上跟你聊过,我不在华科,我在三本学校,你有时间的话我们可以见个面

    Firefox 2012 Firefox 2012 Arch Linux Arch Linux

    yetone Reply:

    @Bentutu.com, 已联系上华科lug负责人

    Avatar

    shylockshao

    Firefox 10.0.2 Firefox 10.0.2 Ubuntu Ubuntu

    March 10th, 2012 at 2:24 pm

    e ...

    Avatar

    shujingjing

    Firefox 10.0.2 Firefox 10.0.2 Windows 7 x64 Edition Windows 7 x64 Edition

    March 10th, 2012 at 10:10 pm

    QQ截图这次被山寨了一把,连快捷键都是一样的。

    Firefox 10.0.2 Firefox 10.0.2 Ubuntu Ubuntu

    yz Reply:

    @shujingjing,
    好用就行了

    Google Chrome 17.0.963.66 Google Chrome 17.0.963.66 GNU/Linux GNU/Linux

    Bentutu.com Reply:

    @yz, 这句话实在!

    Avatar

    kyo

    Google Chrome 17.0.963.79 Google Chrome 17.0.963.79 GNU/Linux GNU/Linux

    March 11th, 2012 at 3:22 pm

    10.04 上安装提示 gconf2 版本低, 但没有找到下升级 gconf 的方法, 在 launchpad 上也没找到升级 gconf 的方法, 请问有解决方法吗?

    Avatar

    oewws

    Google Chrome 7.0.536.2 Google Chrome 7.0.536.2 Windows 7 Windows 7

    March 11th, 2012 at 5:55 pm

    博主写的不错,以后关注你了http://www.qx148.com

    Avatar

    嘿咻复嘿咻

    Google Chrome 19.0.1055.1 Google Chrome 19.0.1055.1 GNU/Linux GNU/Linux

    March 12th, 2012 at 10:02 am

    截取整个应用图片的时候会花屏

    IceWeasel 10.0.2 IceWeasel 10.0.2 GNU/Linux GNU/Linux

    Bentutu.com Reply:

    @嘿咻复嘿咻, 可能你的显卡驱动有问题。

    Google Chrome 19.0.1055.1 Google Chrome 19.0.1055.1 GNU/Linux GNU/Linux

    嘿咻复嘿咻 Reply:

    @Bentutu.com,
    嗯.

    Avatar

    cinepaint.org

    Firefox 10.0.2 Firefox 10.0.2 Mac OS X 10.7 Mac OS X 10.7

    March 12th, 2012 at 5:31 pm

    other more apps needed

    Avatar

    wudada

    Firefox 10.0.2 Firefox 10.0.2 Ubuntu Ubuntu

    March 13th, 2012 at 3:25 pm

    2,打开“系统设置-键盘-快捷键-自定义快捷键”,点击“+”号

    10.04 系统-首选项-键盘快捷键-添加 需要安装Xlib

    Avatar

    peter

    Firefox 10.0.2 Firefox 10.0.2 Ubuntu Ubuntu

    March 14th, 2012 at 9:46 pm

    补充一点,10.04的安装注意了:必须先运行一次代码包里面的updateTranslate.sh,然后截屏工具才能正常运行。

    Firefox 10.0.2 Firefox 10.0.2 Ubuntu Ubuntu

    peter Reply:

    @peter, 当然,10.04的安装还需要xlib,截屏软件才能运行

    Google Chrome 16.0.912.75 Google Chrome 16.0.912.75 Windows XP Windows XP

    jiemar Reply:

    @peter, 10.04下安装失败,我自己捣鼓升级包,直接导致我用了两年的ubuntu重装.坑爹啊

    Avatar

    wo0d.z

    Google Chrome 19.0.1069.0 Google Chrome 19.0.1069.0 Windows 7 Windows 7

    March 15th, 2012 at 12:55 pm

    说实话,截图工具用的不是很多,特别是在现在linux下office不是很好用的时候!

    Avatar

    bitghost

    Firefox 11.0 Firefox 11.0 Ubuntu Ubuntu

    March 17th, 2012 at 10:18 pm

    shutter就行了!

    Avatar

    tolbkni

    Firefox 11.0 Firefox 11.0 GNU/Linux x64 GNU/Linux x64

    March 17th, 2012 at 11:02 pm

    Funtoo 党只能自己写 ebuild 了。

    Firefox 2012 Firefox 2012 Arch Linux Arch Linux

    yetone Reply:

    @tolbkni, 至于嘛,一个py程序而已,直接git clone下来就行了

    Firefox 11.0 Firefox 11.0 Windows 7 x64 Edition Windows 7 x64 Edition

    tolbkni Reply:

    @yetone, 打算放到 gentoo-zh-overlay,目前自己用就是 git clone 纯手工。

    Avatar

    jiemar

    Firefox 3.6.27 Firefox 3.6.27 GNU/Linux GNU/Linux

    March 21st, 2012 at 2:57 am

    使用git clone下来的最新版本的程序,按照10.04的装法 已经失效,求最新的方法 for 10.04

    Firefox 11.0 Firefox 11.0 Ubuntu Ubuntu

    peter Reply:

    @jiemar, 貌似没道理失败吧!你在终端里面运行一下截图程序,看看有什么错误提示,也许只是少了一些运行库而已。我的10.04安装就只需要注意安装xlib,以及运行updateTranslate.sh,就可以了,很容易的啊。

    Firefox 3.6.28 Firefox 3.6.28 GNU/Linux GNU/Linux

    jiemar Reply:

    @peter, 确实如你所言,只是第一次尝试的时候有问题,升级包导致我重装系统,导致我没有再试一次,这次测试成功,同样在ubuntu 10.04下

    Avatar

    Ubuntu 12.04 配置指南 | 笨兔兔

    WordPress 3.2.1 WordPress 3.2.1

    April 26th, 2012 at 6:05 pm

    [...] 安装完毕后,需要绑定启用深度截图工具快捷键 Ctrl+Alt+A,具体请参考文章@wowubuntu [...]

    Avatar

    胡阳

    Google Chrome 18.0.1025.162 Google Chrome 18.0.1025.162 Windows 7 Windows 7

    April 28th, 2012 at 9:29 am

    这个不错,回去试下

    Avatar

    存档 | Wow! Ubuntu

    WordPress 3.3.1 WordPress 3.3.1

    May 11th, 2012 at 1:18 pm

    [...] (更新)Ubuntu 安装 Linux Deepin 截图工具(.deb)  (35) [...]

    Avatar

    Ubuntu 安装 Linux Deepin 截图工具(.deb)(转载) | 我爱吃卤面!

    WordPress 3.3.2 WordPress 3.3.2

    May 30th, 2012 at 9:18 pm

    [...] 作者: Bentutu.com / 本文采用CC BY-NC-SA 2.5协议授权,转载请注明本文链接。 [...]

    Avatar

    ubuntu 12.04设置指南 优化 | weiyuanke的博客

    WordPress 3.2.1 WordPress 3.2.1

    June 2nd, 2012 at 6:21 am

    [...] 安装完毕后,需要绑定启用深度截图工具快捷键 Ctrl+Alt+A,具体请参考文章@wowubuntu [...]

    Avatar

    Ubuntu 12.04配置指南 | 小猪_walker

    WordPress 3.1.4 WordPress 3.1.4

    June 16th, 2012 at 12:13 pm

    [...] 安装完毕后,需要绑定启用深度截图工具快捷键 Ctrl+Alt+A,具体请参考文章@wowubuntu [...]

    Avatar

    王掌柜

    Google Chrome 21.0.1180.60 Google Chrome 21.0.1180.60 Windows 7 Windows 7

    August 5th, 2012 at 11:28 pm

    国人制作的发行版,效果不错

    Avatar

    Ubuntu 安装 Linux Deepin 截图工具[转] | grace

    WordPress 3.2.1 WordPress 3.2.1

    August 10th, 2012 at 10:16 pm

    [...] (更新)Ubuntu 安装 Linux Deepin 截图工具(.deb)9三 2012# 作者: Bentutu.com / 本文采用CC BY-NC-SA 2.5协议授权,转载请注明本文链接。 [...]

    Avatar

    Ubuntu 安装 Linux Deepin 截图工具 | grace

    WordPress 3.2.1 WordPress 3.2.1

    August 11th, 2012 at 12:38 am

    [...] (更新)Ubuntu 安装 Linux Deepin 截图工具(.deb)9三 2012# 作者: Bentutu.com / 本文采用CC BY-NC-SA 2.5协议授权,转载请注明本文链接。 [...]

    Avatar

    hymer

    Google Chrome 23.0.1271.97 Google Chrome 23.0.1271.97 GNU/Linux x64 GNU/Linux x64

    January 8th, 2013 at 10:35 am

    Mint 14.1安装deepin-scrot后无法使用快捷键,重新绑定也无法调出。Cinnamon桌面环境,期待解决

    top